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UWG	's	Previous	Discard	
Procedure
•We deleted items from the 
catalog (and removed OCLC 
holdings) piece by piece
•We did not have an automated 

discard process for physical items, 
only e-books



So	What	Changed?
• In Alma, the following developments caused us 

to reconsider our workflow:
• A high-priority liaison weeding project that 

sent hundreds of items to the Technical 
Services area, typing up carts and work space
• A campus Surplus office request to provide 

title lists for surplussed library materials
• The many mouse clicks required by Alma to 

delete each item, which caused physical 
discomfort and reduced efficiency



UWG's	New	Discard	Procedure
• Our new automated workflow has the following 

advantages:
• One cataloger can withdraw ~200 items (~4 carts) in one 

sitting
• Errors are reduced or eliminated
• The only manual repetitive motion is the scanning of the 

books on the cart and the "Discard" stamping, which can be 
assigned to others if necessary

• Carts are not tied up as long in the Technical Services area
• A title list can be provided to the campus Surplus office
• The Surplus office's pickup schedule and weekly volume 

limits are natural brakes on the project, allowing catalogers 
time to pursue other projects



DISCARD	WORKFLOW



UWG	Discard	Process
1. Liaison librarians or the Stacks Specialist bring carts 

of weeded material to Technical Services

2. Catalogers withdraw material and remove OCLC 

holdings using a two-day process

• Day One: Withdraw items and bib in Alma via manual job

• Day Two: Review any exceptions or errors, batch delete 

holdings in OCLC, and check for USG last copies

3. Catalogers archive surplus title lists and prepare 

discard carts for pickup by Asset Management staff

Today's presentation will focus on step 2.



Discard	Process:	Day	1

Notepad:
Scan the 

barcodes on 
the cart

Analytics:
Add barcodes to 

discard cart report 
template; save as a 

surplus title list

Alma:
Create 

itemized set

Alma:
Run 

Withdraw 
Items job



Discard	Process:	Day	2

Analytics & Alma: 
Review any bibs 
not deleted by 

Withdraw Items 
job

Connexion 
client: 
Batch 
delete 

holdings

Analytics:
Check for 
USG last 
copies

Analytics > Excel:
Request surplus 
pickup and send 
title lists to Asset 

Management 
office 



ANALYTICS	PREPARATION



Institutional	Analytics:	
Discard	Cart	Report	Template
• This template is the basis for each 

discard cart's surplus title list
• To ensure easy access by others in 

Analytics:
• Save the template in your institution's 

shared folders
• Add the template to your Favorites
• Consider keeping all title lists in a dedicated 

folder in Analytics, or save them locally



Discard	Cart	Template:	Fields	to	Add
• Barcode
• Add a filter on this column

• Title
• Title (Filing)
• UWG adds a primary sort to 

this field and hides the column 
in the results

• Description
• UWG renames this field 

'Volume/Year' and adds a 
secondary sort to this field

• Author
• ISBN
• ISSN

• Publisher 
• Publication Date
• Process Type
• Lifecycle
• Bibliographic Lifecycle
• MMS ID
• OCLC Control Number 

(035a) 
• UWG adds conditional 

formatting* to distinguish 
OCLC numbers of bib 
records that were not 
deleted by the Withdraw 
Items job

*In the Criteria tab of your report, select OCLC Number (035a) > 'Column Properties' menu option > 
'Conditional Format' tab > Add Condition > Bibliographic Lifecycle equals 'In Repository' > Edit Format > 'Style' 
tab, then decide on your formatting. UWG uses the cell background color #FF0000, a loud bright red.



NZ	Analytics:	
Last	Copy	Report	Template

• Add these fields to the report:
• OCLC Number 035a
• Add a filter on this column

• Title
• Bibliographic Lifecycle
• Institution Name



NZ	Last	Copy	Report:	Tips
• Do save your NZ report in a dedicated folder for your 

institution in Shared Reports > Galileo Network > 
Reports

• Don't access your NZ report from your institutional 
Analytics (Shared Folders > GALILEO Network > 
Reports)
• Why? Per ExL: "When a member institution runs a report 

acquired from the Network Zone, only data of that member 
institution is displayed"

• Don't add an 'Institutional Name' filter or a 
'Bibliographic Lifecycle' filter to your NZ report

• Don't open NZ Analytics and your institutional 
Analytics  at the same time in the same browser

https://knowledge.exlibrisgroup.com/Alma/Product_Documentation/010Alma_Online_Help_(English)/100Managing_Multiple_Institutions_Using_a_Network_Zone/Analytics_When_Using_a_Network_Zone/Configuring_Analytics_to_Display_Network_Zone_Information


DAY	ONE	PROCESSES



"Day	One"	Basis	of	Activity:	
Barcode	File

Day One Processes
Scanned 

Items from 
Cart

Barcode File (.txt)

Analytics: add as a 
filter; save template 
as surplus title list 

Analytics: check 
item process types

Alma: create 
itemized set for 

Withdraw Items job
Alma: run Withdraw 

Items job on set



Before	you	Begin…
• Tape a numbered 

slip to the cart, 
which will also be 
the name of your 
surplus title list
• This slip will 

follow the discard 
cart on its journey 
through the 
discard process



Create	Barcode	File
• Scan the items on your cart 

into a Notepad++ file
• Add the heading: Barcode
• Scan one barcode per line
• After scanning, compare the 

number of barcodes in your 
file with the number of items 
on your cart

• This file will be used to 
1. Build the Alma set for the 

Withdraw Items job
2. Create the surplus title list for 

that cart



Create	Surplus	Title	List
• Paste the barcodes into the discard cart report template and "save as" to 

create your surplus title list
• Example: UWG uses the naming convention discard cart 27 EDUCATION, based on 

the cart slip
• This surplus title list will be the basis of your Day Two processes (more on this later)



Resolve	Item	Process	Types
Any assigned process types should be resolved before withdrawing 
the items from Alma. Here is what UWG does:

Process Type How to Resolve
Acquisition, Missing, Technical-
Migration

If no notes in item record, scan in item* 
and return to cart

Requested, Transit, Lost, Lost & 
Paid, Claimed Returned, On Hold 
Shelf, Loan

Refer to Circulation department; scan in 
item if directed to do so

In Process 1. Scan in item to see current work 
order department

2. Refer to appropriate staff, or clear 
the In Process status if permitted to 
do so

*Fulfillment > Resource Requests > Scan In Items



Create	Alma	Set
• Admin > Manage Jobs and Sets > Manage Sets
• Click Add Set > Itemized, and enter the following 

parameters:
üSet name: [same as your Notepad file]
üSet content type: Physical items

• In the File box at the bottom, browse to your 
Notepad++ file
• Click Save to submit a job to add members to the set
• The system will email a report when the set is ready
• Check the "Records with exceptions" value in the report to 

see any errors



Add	Members	to	Itemized	Set:	Job	Report
Non-matched records are usually due to an absent or incorrectly entered barcode. 
For more information about these items, check the error file: Navigate to Admin > 
Monitor Jobs > History; search for the job ID (listed in the email as "Process ID"); 
then click the Action button and select Report to download the error file.



Run	Withdraw	Items	Job
• Admin > Manage Jobs and Sets > Run a Job > 

Withdraw Items 
üSelect the set you created previously
üParameters: Delete holdings; delete bibliographic 

records that have no other holdings
• The system will email a report when the job 

completes
• If any items are listed in the "Report Table" section 

of the report, double-check them on Day Two 
(after Analytics is updated with the bib lifecycle 
information)



Withdraw	Items:	Job	Report
• Items with enumeration or chronology are deleted by the 

Withdraw Items job
• Items linked an active PO line are not deleted by the 

Withdraw Items job



Wait	24	hours	for	the	
ETL	process	to	update	
data	in	Analytics



DAY	TWO	PROCESSES



"Day	Two"	Basis	of	Activity:	
Surplus	Title	List

Day Two Processes
Analytics 

Report from 
Day One

Surplus title list

Investigate any bibs 
that were not deleted 
by the Withdraw Items 

job

Batch delete OCLC 
numbers in Connexion 

client

Check for last copies 
using NZ Analytics 

report

Submit pickup request 
to Surplus office

Email title lists to 
Surplus office



Prepare	OCLC	Number	File
• Copy the OCLC numbers from the surplus title list, to a Notepad file
• Enter the numbers only; the system will ignore any characters preceding the OCLC numbers
• If the surplus title list shows that any bib records were not deleted, investigate those bibs 

before adding their OCLC numbers to your Notepad file
• The example below shows UWG's conditional formatting for the 'OCLC Control Number (035a)' 

field



Review	any	Bibs	not	Deleted	
by	Withdraw	Items	Job
Here are some common scenarios identified at UWG:

Situation How to Fix Delete
OCLC 
Holdings?

Missing or lost items remain on 
the bib.

Suppress the bib and delete OCLC 
holdings in accordance with UWG 
lost and missing procedures. 

Yes

Additional volumes of a multi-part 
monograph remain on the bib, 
but the 866 summary holdings 
need to be updated.

Give the discarded item(s) to the 
serials cataloger to update the 
866 and the OCLC LHR.

No

Additional copies remain on the 
bib.

No fix required! No



Connexion	Client	Preparation
• Tools > Options > Authorizations
• Make sure you have an authorization set as 

the default 
• Tools > Options > Batch
• Check box next to "Display batch reports 

automatically" and, optionally, "Print batch 
reports automatically"

• For more information on batch processing, refer 
to the Connexion client documentation

https://help.oclc.org/Metadata_Services/Connexion/ConnexionClient/Connexion_client_documentation?sl=en


Batch	Delete	OCLC	Holdings
Batch > Holdings by OCLC number

1. Browse to your OCLC number text file and click Import
2. Decide if you want to delete the source file
3. Tick the box next to Delete Holdings, and click OK



Batch	Delete	OCLC	Holdings	
(cont.)

• After the system deletes your holdings, a confirmation report will 
display in the client, which will also alert you to any errors



Check	for	Last	Copies
• Last Copy in Georgia policy is available on 

the Cataloging wiki
• The last copy check can be done at any 

point in the discard process; do what 
works for your institution
• You can also check last copies using the 

Last Copy app; ask GIL Support for details

https://drive.google.com/file/d/18IgPpUm5JcN1tvLToG9oHAdQEqqDW84Y/view?usp=sharing
https://sites.google.com/view/g3almatraining/cataloging/last-copy-in-georgia


NZ	Analytics:	Last	Copy	Report
• To check for last copies, open your NZ report and paste your OCLC 

numbers into the 'OCLC Control Number 035a' filter
• A last copy will show either as a single row (see highlighted example 

below) or as multiple rows, each with a Bib Lifecycle of 'Deleted'



Prepare	Carts	for	Pickup	by	Asset	
Management	(aka	"Surplus	Office")

Photo credits: Miriam Nauenburg

Email & Web Form

Request surplus pickup Email title lists to Asset 
Management Coordinator

Back Hallway

Add 'For Surplus' signs to carts

Technical Services

Stamp items as discarded
Delete any last copies from 

title lists and remove from carts



SUMMARY



Tips	and	Tricks
• In Analytics, save your discard cart report template as a 

Favorite in one of your institutional shared folders
• Handle any assigned process types before running the 

Withdraw Items job
• Check the following job reports and handle any problems 

before proceeding: 
• 'Add Members to Itemized Set' job report, to confirm that all 

scanned barcodes from your cart were added to the set
• 'Withdraw Items' job report, to confirm that all items in your set 

were withdrawn from Alma
• OCLC holdings deletion report, to confirm that all OCLC holding 

were removed
• When checking last copies, access your NZ Analytics report 

from the NZ, not your institutional Analytics



QUESTIONS?


